Email Delivery Deyaled

Minor incident Datacentre DC14 Anti-Spam Cluster
2022-09-21 10:02 BST · 1 hour, 40 minutes

Updates

Resolved

Our suppliers have made a configuration change to the platform and we can now see the mail queue dispatching to customers.
There is a generous queue still to process, which we would anticipate cleared in the next ten minutes or so.

Apologies for the inconvenience

September 21, 2022 · 11:42 BST
Update

We are continuing to engage with our platform suppliers to address the root cause of the problem, and they are actively working on restoration.
Once again, all email is being safely stored and will be delivered upon full restoration.

September 21, 2022 · 11:36 BST
Issue

We have become aware of a growing email queue on our Anti-Spam platform.
Initial checks have not revealed the reason, so a support case is being raised with the supplier for investigation.
All email is safely queued and will be dispatched to the intended recipient as soon as service is restored.

September 21, 2022 · 10:03 BST

← Back