Inbound Calling Issues

Minor incident VoIP Services Call Handling Call Routing
2024-11-20 10:32 GMT · 59 minutes

Updates

De-escalate

The issue affecting inbound calls this morning is now cleared.

Our engineers are in the process of investigating and more details will follow as soon as we can.

We sincerely apologise for the disruption this morning.

November 20, 2024 · 11:31 GMT
Resolved

Our engineers are in the process of investigating and more details will follow as soon as we can.

We sincerely apologise for the disruption this morning.

November 20, 2024 · 11:31 GMT
Investigating

Following on from the below notice - we are aware that customers have experienced issues with both inbound calls this morning.

Engineers have located the cause and are in the process of fully restoring service - more updates will follow as soon as they are available.

November 20, 2024 · 10:59 GMT
Issue

We are receiving multiple customer reports of inbound calls failing to connect.
Outbound services are performing normally.

A case has been raised with the carrier.

November 20, 2024 · 10:32 GMT

← Back