ITS Leased Line Outage

Major incident Leased Lines ITS
2026-01-29 15:55 GMT · 27 minutes

Updates

Resolved

ITS have advised the issue is resolved stating:

“We noticed an issue on our network which caused an outage today from15:55. This was identified by our monitoring tools instantly and we restored services by 16:20. We apologize for any inconvenience caused during this time”

We have requested an RFO and this will be available for review as soon as received by ourselves.

Apologies for any inconvenience.

January 29, 2026 · 16:22 GMT
Monitoring

Service has resumed across the estate, but still no formal update from the carrier as yet

January 29, 2026 · 16:20 GMT
Investigating

ITS have acknowledged the fault and are actively working upon the issue, but presently there is no ETA for return to service.

January 29, 2026 · 16:14 GMT
Issue

Monitoring is reporting all our ITS based connectivity services, including Leased Lines and FTTP services are out of service.

The issue is being raised with the carrier, although they have already confirmed we are not the only ISP affected

January 29, 2026 · 15:55 GMT

← Back