Office Phone System Outage

Minor incident CCS Office Phone System
2022-07-15 15:37 BST · 4 hours, 16 minutes

Updates

Resolved

Intermittent Serivce was evident throughout the past few hours, and has now been resolved after thorough testing. Apologies for any inconvenience.

July 15, 2022 · 19:54 BST
Investigating

We are aware of failing inbound call on our main office number at present, and the cause is being investigated.

All staff are in the office as normal, so please email the relevant department at support / account / provisioning etc

Apologies for the inconvenience

July 15, 2022 · 15:38 BST

← Back